IF Competition Discussion: A Fine Day for Reaping

Comments on A Fine Day for Reaping from IF Comp 2007.

A Fine Day for Reaping is a comic puzzle game in which you, as Death, have to go around the world seeing to the dispatch of particularly difficult souls. As Grim Reapers go, though, you’re not endowed with that many special powers, so you’ll have to rely on your wits and an odd combination of tricks and tools to get the job done.

In conception, this is a pretty good game. It owes a large debt to Terry Pratchett, but since I happen to enjoy Pratchett in the right mood (especially the Death books), I didn’t mind that so much. The writing is decent to better-than-decent. The puzzles range from the reasonable to infuriatingly obscure, but since most of them have multiple solutions, it’s usually possible to find *something* that works. (And then check out the walkthrough for alternate solutions and endings.) The execution? Also mostly decent.

The big drawback is the parser. A Fine Day for Reaping has an incredibly finicky, annoying parser, one that will pretend not to know verbs that you’ll need to use later, claim that important objects are useless, reject reasonable synonyms, ask disambiguation questions that don’t actually work to disambiguate, and generally do its level best to confuse you and throw you off-track. So I hesitate to recommend this, especially to anyone who isn’t a die-hard IF fan with a lot of parser-wrangling experience, because of all the messed-up exchanges…









Like this, for instance:

> x button

The buttons next to the digital readout are all blue except for the red one. Above the red one are two lights, one lit and one not. Next to the lights are, scrawled in biro on the machine itself, are the initials ‘BC’ and ‘AD’. The light that is currently lit is the one next to ‘AD’.

> press red
You press, but nothing happens.

> press bc
You press, but nothing happens.

> bc

That didn’t make any sense to me.

> push bc button
You push, but nothing happens.

> press bc button
You press, but nothing happens.

> press red button

[Stuff happens.]

or this:

> x uniform

The uniform belonging to a female Captain in the United States Armed Forces. A feeling of dread descends over you as you realise that, at some point today, you’re probably going to have to wear it.

> wear it
(the military uniform)
You can’t wear the military uniform.


> get in machine
Take what?

> enter machine
You climb back into the time machine…

or the completely arbitrary way that some objects you can read with EXAMINE but others you have to read with READ. (And in the wrong context, the game pretends not to know the word READ.) This kind of thing is so, SO annoying, and so unnecessary.

There was also at least one puzzle that I thought of the right solution to (at least according to the walkthrough) but the game refused to allow me to pick up the item I needed to implement it (the masking tape). I never figured out why, or what trigger controlled my access.

It’s too bad about all that, because in other respects I did like this game quite a lot, but the interaction is so clumsy, so backward, so annoying that I have mixed feelings about recommending it to anyone. This really needs a serious going-over by a team of extra beta-testers.

4 thoughts on “IF Competition Discussion: A Fine Day for Reaping”

  1. I wasn’t as annoyed by the parser as you were, probably because I played or tried to play “Eduard the Seminarist” directly before, but the masking tape problem nearly drove me mad, too. Until I realized that I wasn’t supposed to take the masking tape, but to repair the thing in the room where the masking tape was lying.
    Talking about counter-intuitive.

  2. I was pretty sure I tried “REPAIR” too (in the correct location), but it wouldn’t let me. Possibly I didn’t phrase the command exactly right, but if so, that reinforces my point. Even after I’d looked at the walkthrough and confirmed that what I was attempting was the right solution, I couldn’t make it happen in the game.

    This all just seemed completely arbitrary to me anyway. The game lets you pick up all sorts of other things; why not let the player carry the masking tape around all game, too? Why is that the one thing where we have to know what it’s for in order to interact with it?

  3. Yes, that was one of these moments of “what the hell is the author thinking!?” that are getting harder to tolerate the more comp games I play. I was probably just lucky to use the “right” command early on.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: